Hooked up battery wrong on Lexus SC300?

Reply
 
LinkBack Thread Tools Display Modes
Old 22 Oct 2013, 07:39 pm   #1 (permalink)
pj
Junior Member
  • Join Date: Mar 2010
  • Posts: 13
  • User Status: Offline


Default Hooked up battery wrong on Lexus SC300?

Just recently got my 1995 Lexus SC300 and hooked up the battery on the wrong terminals ( - on + and + on - ). car wont start. How could I fix this?
  Reply With Quote
Old 22 Oct 2013, 07:54 pm   #2 (permalink)
Junior Member
  • Join Date: Oct 2013
  • Posts: 1
  • User Status: Offline


Default

Ask your friend to borrow his Battery, if it works then the battery is bad, if not then you must replace the and - cables or terminals.
  Reply With Quote
Old 22 Oct 2013, 08:10 pm   #3 (permalink)
Junior Member
  • Join Date: May 2010
  • Posts: 4
  • User Status: Offline


Default

PJ, the dumbest blonde in the world could not mange that screw up...... New battery & a visit to America's Best for a eye exam...
  Reply With Quote
Old 22 Oct 2013, 08:24 pm   #4 (permalink)
Junior Member
  • Join Date: Oct 2013
  • Posts: 5
  • User Status: Offline


Default

You probably blew a fuse. Check the fuses box.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:34 pm.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.