2006 scion xa check engine light has been turning on and off for the past 3 month, please help :(?

Reply
 
LinkBack Thread Tools Display Modes
Old 17 Jun 2013, 01:24 pm   #1 (permalink)
Junior Member
  • Join Date: Jun 2013
  • Posts: 1
  • User Status: Offline


Default 2006 scion xa check engine light has been turning on and off for the past 3 month, please help :(?

I have a 2006 scion xa and the check engine light has been turning on and off for the pass three months. OBD # P0171 came up when I had the car checked. So far I have replaced the spark plugs, gas cap, and mass air-flow sensor. The auto shop said it was the mass air-flow sensor because the system is running too lean. I have no idea why the check engine still come on every 2-3 wks. I'm frustrated and don't want to waste anymore money fixing the wrong problem. If anyone can help me figure out I would greatly appreciate it. Thanks!
  Reply With Quote
Old 17 Jun 2013, 01:39 pm   #2 (permalink)
Senior Member
  • Join Date: Feb 2010
  • Posts: 299
  • User Status: Offline


Default

Personally I would just ignore it. Mine's comes on occasionally and everytime the codes point to a gas valve clog and everytime my gas valve clog is clean as a thing that is clean. Yeah...
  Reply With Quote
Old 17 Jun 2013, 01:54 pm   #3 (permalink)
Member
  • Join Date: May 2010
  • Posts: 66
  • User Status: Offline


Default

So...you spent a ton of money loading up the parts cannon and firing random parts at your car and finally ask for help? Hmmmm.































Your shop is guessing, too. Try another one.































Sounds like a vacuum leak is present. Find it.































That's about all the help you can get over the Internet.































See your car in the driveway? That's not what we see here.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:10 pm.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.