2005 scion xb cold running light(blue) won't turn off even long after warmed up.?

Reply
 
LinkBack Thread Tools Display Modes
Old 01 Mar 2014, 05:34 am   #1 (permalink)
Junior Member
  • Join Date: Sep 2012
  • Posts: 2
  • User Status: Offline


Default 2005 scion xb cold running light(blue) won't turn off even long after warmed up.?

On the first gen scion xb there is a feature on the automatics that disable the overdrive so the engine will warm up faster if it's driven before it goes away. My car has been past warmed up lately and the light won't turn off even while the vents are blasting hot air. This is causing my car to never go past 4th gear. What would be the issue here and how could I fix it?
  Reply With Quote
Old 01 Mar 2014, 05:39 am   #2 (permalink)
Junior Member
  • Join Date: Jan 2014
  • Posts: 6
  • User Status: Offline


Default

Sounds like a temp sensor is gone bad.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:46 pm.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.