Windshield Washer Fluid Pump

Reply
 
LinkBack Thread Tools Display Modes
Old 29 Dec 2008, 08:53 pm   #1 (permalink)
hibb
Guest
  • Posts: n/a
  • User Status:


Default Windshield Washer Fluid Pump

Looks like it quit working on my 2004 Camry. Is there an easy
diagnostic to make sure just what the problem is? I already checked
the fuse and it looks ok.

Is this a tough job to remove and install a new one?

Thanks, David
  Reply With Quote
Old 31 Dec 2008, 03:09 pm   #2 (permalink)
Daniel
Guest
  • Posts: n/a
  • User Status:


Default Re: Windshield Washer Fluid Pump

hibb wrote:
> Looks like it quit working on my 2004 Camry. Is there an easy
> diagnostic to make sure just what the problem is? I already checked
> the fuse and it looks ok.
>
> Is this a tough job to remove and install a new one?

========
The only time I had a washer pump fail was on a Mercedes. Turns out
the common blue washer fluid can crystallize with age and clog a pump.
First though, I'd check the washer nozzles. If they're plugged with
car wax they can be carefully cleaned with a pin.
  Reply With Quote
Old 31 Dec 2008, 06:35 pm   #3 (permalink)
ransley
Guest
  • Posts: n/a
  • User Status:


Default Re: Windshield Washer Fluid Pump

On Dec 29, 8:53*pm, hibb <ShyPic...@aol.com> wrote:
> Looks like it quit working on my 2004 Camry. Is there an easy
> diagnostic to make sure just what the problem is? I already checked
> the fuse and it looks ok.
>
> Is this a tough job to remove and install a new one?
>
> Thanks, David


My 91 had the pump under the washer tank and the wheel well skirt had
to be removed to unscrew the tank from below, thats why mechanics bid
155$ to put in a 15$ pump. If its working you will hear it, if its
hard to get to wires go to it so it can be jumped, it could be the
switch on the stalk. Maybe yours is easier to replace.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:28 am.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.