1998 Avalon idles rough (1500 rpm)

Reply
 
LinkBack Thread Tools Display Modes
Old 03 Aug 2010, 08:17 pm   #1 (permalink)
Figaro
Guest
  • Posts: n/a
  • User Status:


Default 1998 Avalon idles rough (1500 rpm)

My 1998 Avalon XLS has been idling rough and noisy (relatively) for a
few years now (It has 146k mi). When I first bought the car at 50k
mi, it was near-silent at idle and the RPM was under 1000.

I had replaced ignition coils and cleaned the throttle body valve last
year, that got it more smooth and quieter for a while. Now it's back
to being rough and noisy. The idle RPM never goes lower than 1500...
my mechanic says it's normal.

Any suggesions on what to do next?

Thanks!

  Reply With Quote
Old 04 Aug 2010, 09:03 am   #2 (permalink)
hls
Guest
  • Posts: n/a
  • User Status:


Default Re: 1998 Avalon idles rough (1500 rpm)


"Figaro" <ponsellite@gmail.com> wrote in message
news:a52c1020-c3a2-48ac-b4e6-a0881aa2859d@i4g2000prf.googlegroups.com...
> My 1998 Avalon XLS has been idling rough and noisy (relatively) for a
> few years now (It has 146k mi). When I first bought the car at 50k
> mi, it was near-silent at idle and the RPM was under 1000.
>
> I had replaced ignition coils and cleaned the throttle body valve last
> year, that got it more smooth and quieter for a while. Now it's back
> to being rough and noisy. The idle RPM never goes lower than 1500...
> my mechanic says it's normal.
>
> Any suggesions on what to do next?
>
> Thanks!


Have you ever replaced the ignition cables? I would hope so if you
replaced the coils.

I dont know when you are supposed to replace the timing belt or chain
on that one (and that is embarassing because we own a 2007 Avalon)
but it might be worth checking.

Vacuum leaks are always to be suspected when there are roughness and
idle issues.


  Reply With Quote
Old 04 Aug 2010, 11:57 am   #3 (permalink)
Figaro
Guest
  • Posts: n/a
  • User Status:


Default Re: 1998 Avalon idles rough (1500 rpm)

On Aug 4, 7:03*am, "hls" <h...@nospam.nix> wrote:
> "Figaro" <ponsell...@gmail.com> wrote in message
>
> news:a52c1020-c3a2-48ac-b4e6-a0881aa2859d@i4g2000prf.googlegroups.com...
>
> > My 1998 Avalon XLS has been idling rough and noisy (relatively) for a
> > few years now (It has 146k mi). * When I first bought the car at 50k
> > mi, it was near-silent at idle and the RPM was under 1000.

>
> > I had replaced ignition coils and cleaned the throttle body valve last
> > year, that got it more smooth and quieter for a while. *Now it's back
> > to being rough and noisy. *The idle RPM never goes lower than 1500...
> > my mechanic says it's normal.

>
> > Any suggesions on what to do next?

>
> > Thanks!

>
> Have you ever replaced the ignition cables? *I would hope so if you
> replaced the coils.
>
> I dont know when you are supposed to replace the timing belt or chain
> on that one (and that is embarassing because we own a 2007 Avalon)
> but it might be worth checking.
>
> Vacuum leaks are always to be suspected when there are roughness and
> idle issues.


I replaced the timing belt 40k mi ago. Will take it to my mechanic
this weekend for a checkup.

How do you like your '07 Avalon? To me that's just as smooth as a
Lexus ES and more roomy (and cheaper!)
  Reply With Quote
Old 05 Aug 2010, 07:22 pm   #4 (permalink)
hls
Guest
  • Posts: n/a
  • User Status:


Default Re: 1998 Avalon idles rough (1500 rpm)


"Figaro" <ponsellite@gmail.com> wrote in message news:b8989db3-5ce7-
How do you like your '07 Avalon? To me that's just as smooth as a
Lexus ES and more roomy (and cheaper!)

It has been a dream car. Smooth, fast, and very economical. Never any
problems. This is the kind of ride I dreamed about as a young boy.

  Reply With Quote
Old 06 Aug 2010, 07:21 am   #5 (permalink)
ransley
Guest
  • Posts: n/a
  • User Status:


Default Re: 1998 Avalon idles rough (1500 rpm)

On Aug 3, 8:17*pm, Figaro <ponsell...@gmail.com> wrote:
> My 1998 Avalon XLS has been idling rough and noisy (relatively) for a
> few years now (It has 146k mi). * When I first bought the car at 50k
> mi, it was near-silent at idle and the RPM was under 1000.
>
> I had replaced ignition coils and cleaned the throttle body valve last
> year, that got it more smooth and quieter for a while. *Now it's back
> to being rough and noisy. *The idle RPM never goes lower than 1500...
> my mechanic says it's normal.
>
> Any suggesions on what to do next?
>
> Thanks!


Dump that mechanic, he is a moron, 1500 isnt normal, 6-700 is, if it
cant idle at 600 smoothly you have more to fix. How old are wires and
plugs, what is plug condition, as you can Read alot on a motors
condition by plugs, Bottom line you need a new mechanic. To just
replace all coils first before plugs and wires without proving ones is
bad is also dumb and ripped you off, what you do is replace a bad coil
you have tested, not all of them first. Coils rarely go bad, and its
usualy one at a time, but with a bad coil could be a fouled plug from
lack of voltage. Was it put on a scope, start there and with plugs and
maybe wires.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:01 am.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.