91 4 cil Injector bad?

Reply
 
LinkBack Thread Tools Display Modes
Old 23 Dec 2004, 05:17 pm   #1 (permalink)
m Ransley
Guest
  • Posts: n/a
  • User Status:


Default 91 4 cil Injector bad?

My car started fine today then started to miss thinking bad gas I put
in heat and high octane as it is 15f. It just got worse missing only on
aceleration not Idle on one cilinder. A mechanic located the one . So I
changed that plug which started to burn white indicating a lean fuel
condition, another plug was black-rich burn. Spark is good so now I
think the injector is bad on one cilinder. Other wires I have found
corroded in lamp connectors. So is it possible the plug in harness
contacts for the injector are corroded or does this sound like a bad
injector. I was going to travel today and tomorrow most mechanics will
not look at it. It looks like replacing an injector is not easy it will
be 0 tomorrow, Ive never done it and have limited tools. . The one
cilinder fires at idle but starves-no fire on aceleration. Plugs 5000m
wires 30000, air filter good. motor compression condition very good. One
new plug on bad cilinder no difference. Should I get a rental and take
it to the shop. Or might it be somthing I can fix, maybe bad contacts on
injector harness

  Reply With Quote
Old 23 Dec 2004, 07:15 pm   #2 (permalink)
Jason James
Guest
  • Posts: n/a
  • User Status:


Default Re: 91 4 cil Injector bad?


"m Ransley" <ransley@webtv.net> wrote in message
news:10344-41CB5209-965@storefull-3137.bay.webtv.net...
> My car started fine today then started to miss thinking bad gas I put
> in heat and high octane as it is 15f. It just got worse missing only on
> aceleration not Idle on one cilinder. A mechanic located the one . So I
> changed that plug which started to burn white indicating a lean fuel
> condition, another plug was black-rich burn. Spark is good so now I
> think the injector is bad on one cilinder. Other wires I have found
> corroded in lamp connectors. So is it possible the plug in harness
> contacts for the injector are corroded or does this sound like a bad
> injector. I was going to travel today and tomorrow most mechanics will
> not look at it. It looks like replacing an injector is not easy it will
> be 0 tomorrow, Ive never done it and have limited tools. . The one
> cilinder fires at idle but starves-no fire on aceleration. Plugs 5000m
> wires 30000, air filter good. motor compression condition very good. One
> new plug on bad cilinder no difference. Should I get a rental and take
> it to the shop. Or might it be somthing I can fix, maybe bad contacts on
> injector harness



Sounds like the plug lead or the distributor cap is cracked or tracked to
ground. Ignition loss under acceleration means the spark is taking "the
easiest (read: lowest resistance) path to ground" elsewhere than across the
plug.
When the engine starts to work harder, the air-fuel intake increases and
presents across the sparkplug gap as a higher resistance.

Jason


  Reply With Quote
Old 23 Dec 2004, 10:54 pm   #3 (permalink)
m Ransley
Guest
  • Posts: n/a
  • User Status:


Default Re: 91 4 cil Injector bad?

How can I tell if it is ignition loss. Wouldnt a bad fuel injector do
this, a lean condition. My bad cilinder started to burn white.

  Reply With Quote
Old 24 Dec 2004, 12:54 pm   #4 (permalink)
m Ransley
Guest
  • Posts: n/a
  • User Status:


Default Re: 91 4 cil Injector bad?

It was the plug wire, crappy 3 yr old 12000m on them after market junk.
I am sick of aftermarket junk, My aftermarket thermostats last 3 yrs.,
plug wires 3-4 yrs. I bought 2 plug sockets yesterday before returning
both, they would not hold the plug in. They were Tiawan crap. You cant
be sure of aftermarket junk anymore. I know this has been going on for
years but it seems worse. So my new wires and cap are aftermarket 70$. I
wonder how long they will last. For one lousy bad 3$ wire it cost me
135$ today. Well at least it was not the injector.

  Reply With Quote
Old 24 Dec 2004, 01:37 pm   #5 (permalink)
Jason James
Guest
  • Posts: n/a
  • User Status:


Default Re: 91 4 cil Injector bad?


"m Ransley" <ransley@webtv.net> wrote in message
news:22957-41CC65D4-454@storefull-3132.bay.webtv.net...
> It was the plug wire, crappy 3 yr old 12000m on them after market junk.
> I am sick of aftermarket junk, My aftermarket thermostats last 3 yrs.,
> plug wires 3-4 yrs. I bought 2 plug sockets yesterday before returning
> both, they would not hold the plug in. They were Tiawan crap. You cant
> be sure of aftermarket junk anymore. I know this has been going on for
> years but it seems worse. So my new wires and cap are aftermarket 70$. I
> wonder how long they will last. For one lousy bad 3$ wire it cost me
> 135$ today. Well at least it was not the injector.



Yes, its a bit depressing when you buy in good-faith aftermarket parts and
they are garbage. I mean dont they too have to live up to some informal
industry standard? 3 yrs is not good enough.

I bought an aftermarket t'stat once and it was faulty (stayed shut). A
lesson learned.

Jason


  Reply With Quote
Old 24 Dec 2004, 03:38 pm   #6 (permalink)
ROBMURR
Guest
  • Posts: n/a
  • User Status:


Default Re: 91 4 cil Injector bad?

>It was the plug wire, crappy 3 yr old 12000m on them after market junk.
>I am sick of aftermarket junk, My aftermarket thermostats last 3 yrs.,


Sure is not worth saving a couple bucks using cheap parts...
Lesson learned. Glad you got it fixed.
  Reply With Quote
Old 02 Jan 2005, 08:43 pm   #7 (permalink)
John
Guest
  • Posts: n/a
  • User Status:


Default Re: 91 4 cil Injector bad?

I use aftermarket parts for non critical bits. Thermostats and similar I
always buy genuine.
John
"ROBMURR" <robmurr@aol.com> wrote in message
news:20041224163824.08274.00002496@mb-m05.aol.com...
> >It was the plug wire, crappy 3 yr old 12000m on them after market junk.
>>I am sick of aftermarket junk, My aftermarket thermostats last 3 yrs.,

>
> Sure is not worth saving a couple bucks using cheap parts...
> Lesson learned. Glad you got it fixed.



  Reply With Quote
Old 03 Jan 2005, 12:13 am   #8 (permalink)
Viperkiller
Guest
  • Posts: n/a
  • User Status:


Default Re: 91 4 cil Injector bad?

On Mon, 03 Jan 2005 02:43:16 GMT, "John" <**johnnyboy@dodo.com.au>
wrote:

>I use aftermarket parts for non critical bits. Thermostats and similar I
>always buy genuine.
>John



What would you consider "non critical bits"?
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:18 pm.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.