tranny problem? please help...

Reply
 
LinkBack Thread Tools Display Modes
Old 28 Apr 2005, 04:31 am   #1 (permalink)
nbruin@gmx.net
Guest
  • Posts: n/a
  • User Status:


Default tranny problem? please help...

Hi everyone,

Yesterday I was making a left turn and suddenly my 89 Camry (4cyl auto)
started having problems shifting into second. I took the car to a few
places (none of them my mechanic since its a long drive to his shop)
and none could say for certain what was wrong. I recently had the right
front strut fixed and transmission mounts replaced (the left strut is
still bad and needs to be replaced soon). Might my problem have
anything to do with the recent work or the bad left strut??? This group
almost always gives good advice... your help is really appreciated.
Thanks.

Nathan

  Reply With Quote
Old 28 Apr 2005, 07:01 am   #2 (permalink)
m Ransley
Guest
  • Posts: n/a
  • User Status:


Default Re: tranny problem? please help...

When is the last time you fluid and filter were replaced.

  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:20 am.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.