1997 Camery 2.2 L4 engine failure: dashboard lights wrong

Reply
 
LinkBack Thread Tools Display Modes
Old 12 Mar 2006, 12:53 am   #1 (permalink)
michaelwwwwww@yahoo.com
Guest
  • Posts: n/a
  • User Status:


Default 1997 Camery 2.2 L4 engine failure: dashboard lights wrong

My 1997 Camery has been running smoothly until this morning when it
refused to start, even after I tried to jump it. I replaced the battery
and alternator (using a 1994 model) and was able to drive 50 miles
without any problem. I then replaced 1994 model with a 1997 model,
started the car and drove about 1 mile without any problem, had to stop
for some food, then started the car without any problem, but was only
able to drive about 1/4 mile and all of a sudden, the dashboard lights
started flashing and the rain wiper started moving and the car stopped
completely. I then put my key inside inition, only some dashboard
lights were on (ABS and oil), but not the check engine light. Starter
cranks, engine turns, but there is no sign of ignition at all and the
engine refused to turn on. I had to tow it back home ...... I checked
the battery and the voltage is 12.8v, no sparking when I tried to start
the engine.

Is it because the computer board is all messed up or is it due to some
other problems? Any idea how I can fix the problem is greatly
appreciated!

  Reply With Quote
Old 13 Mar 2006, 10:34 am   #2 (permalink)
davidj92
Guest
  • Posts: n/a
  • User Status:


Default Re: 1997 Camery 2.2 L4 engine failure: dashboard lights wrong

michaelwwwwww@yahoo.com wrote:
> My 1997 Camery has been running smoothly until this morning when it
> refused to start, even after I tried to jump it. I replaced the
> battery and alternator (using a 1994 model) and was able to drive 50
> miles without any problem. I then replaced 1994 model with a 1997
> model, started the car and drove about 1 mile without any problem,
> had to stop for some food, then started the car without any problem,
> but was only able to drive about 1/4 mile and all of a sudden, the
> dashboard lights started flashing and the rain wiper started moving
> and the car stopped completely. I then put my key inside inition,
> only some dashboard lights were on (ABS and oil), but not the check
> engine light. Starter cranks, engine turns, but there is no sign of
> ignition at all and the engine refused to turn on. I had to tow it
> back home ...... I checked the battery and the voltage is 12.8v, no
> sparking when I tried to start the engine.
>
> Is it because the computer board is all messed up or is it due to some
> other problems? Any idea how I can fix the problem is greatly
> appreciated!


Check to make sure you got all the wires hooked tight on battery connections
and alternator and all connections are clean. You could have an alternator
problem, either the brushes are bad or the (internal)voltage regulator has a
problem.
I suggest you get the battery load tested. It sounds like you could have an
intermittant internal shorted cell which sometimes will only show up under a
load test. Autozone will do these tests for free.
Dave


  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:30 am.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.