91 camry stalling

Reply
 
LinkBack Thread Tools Display Modes
Old 21 Mar 2006, 08:01 pm   #1 (permalink)
News
Guest
  • Posts: n/a
  • User Status:


Default 91 camry stalling

I have 91 camry (2.0L, 4 cylinder, 190000km). It was running very well until
one month ago. One day it was stalling once at red traffic light. I could
restarted and drive. Suddenly another day, I could start it but it will
stall when I shift speed to RETURN or DRIVE. It was checked at Canadian Tire
and they could not find where the problem is. They said they changed fuel
filter and checked the air mass meter, costing $110. It didn't fix anything
and it becomes worse and worse. Now I have difficult to start. I moved a
good bettery on it from my another car. it could be stared but it stalled
after 1 minutes. If I press gas hardly, it can run with strange noise (like
something bombing in muffuller).

I tried a new coolant temperture sensor and it didn't solve the problem. I
also noticed the charged battery became 0 voltage after 24 hours. I played
with a multimeter and found by occasion the resistance between engine body
and the possitive end of battery line is almost zero (the negative was
diconnected already). Not sure if this courses the stalling problems. I
changed the engine oil and filter (filter is one year old) and will try
again.
Any boday can give some advises, please. Thank you in advance.

Ron





  Reply With Quote
Old 22 Mar 2006, 05:08 am   #2 (permalink)
Jason James
Guest
  • Posts: n/a
  • User Status:


Default Re: 91 camry stalling


"News" <rjyan@hotmail.com> wrote in message
news:bg2Uf.3149$qX6.127523@news20.bellglobal.com.. .
> I have 91 camry (2.0L, 4 cylinder, 190000km). It was running very well

until
> one month ago. One day it was stalling once at red traffic light. I could
> restarted and drive. Suddenly another day, I could start it but it will
> stall when I shift speed to RETURN or DRIVE. It was checked at Canadian

Tire
> and they could not find where the problem is. They said they changed fuel
> filter and checked the air mass meter, costing $110. It didn't fix

anything
> and it becomes worse and worse. Now I have difficult to start. I moved a
> good bettery on it from my another car. it could be stared but it stalled
> after 1 minutes. If I press gas hardly, it can run with strange noise

(like
> something bombing in muffuller).


That noise is either, blow-back into the aircleaner whih brings into
question valve or ignition timimng, or its the muffler baffles rattling n
side which could cause a blocked exhaust. Both these conditions can stall
the engine.

Jason


> I tried a new coolant temperture sensor and it didn't solve the problem. I
> also noticed the charged battery became 0 voltage after 24 hours. I played
> with a multimeter and found by occasion the resistance between engine body
> and the possitive end of battery line is almost zero (the negative was
> diconnected already). Not sure if this courses the stalling problems. I
> changed the engine oil and filter (filter is one year old) and will try
> again.
> Any boday can give some advises, please. Thank you in advance.
>
> Ron


Thereshould have been no resistance with the -ve terminal disconnected. Have
you measured current drain from the battery with the car'off',..no lights
etc. This is the usual current metering to unwanted discharge.

Jason


  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:08 pm.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.