Turn signal blinks fast when breaking

Reply
 
LinkBack Thread Tools Display Modes
Old 07 May 2006, 03:50 pm   #1 (permalink)
Mike
Guest
  • Posts: n/a
  • User Status:


Default Turn signal blinks fast when breaking

I have a '97 Camry. Recently I've noticed that the left turn signal
blinks fast, but only when my foot is on the break. The signal still
works (in the front & in the back). Does anyone know if this is a bulb
replacement issue...or is there perhaps a different explanation?

Thank you in advance for any advice!

Mike

  Reply With Quote
Old 07 May 2006, 04:23 pm   #2 (permalink)
m Ransley
Guest
  • Posts: n/a
  • User Status:


Default Re: Turn signal blinks fast when breaking

It should be a bad bulb or connection, at least that happens when one
bulb doesnt work or a corroded conection doesnt allow the bulb to work,
but the brake issue ive never seen, try to see what bulb does not work
first

  Reply With Quote
Old 07 May 2006, 06:31 pm   #3 (permalink)
Mark A
Guest
  • Posts: n/a
  • User Status:


Default Re: Turn signal blinks fast when breaking

"Mike" <brummm@blue.weeg.uiowa.edu> wrote in message
news:1147035021.403827.83900@e56g2000cwe.googlegro ups.com...
>I have a '97 Camry. Recently I've noticed that the left turn signal
> blinks fast, but only when my foot is on the break. The signal still
> works (in the front & in the back). Does anyone know if this is a bulb
> replacement issue...or is there perhaps a different explanation?
>
> Thank you in advance for any advice!
>
> Mike
>


Common problem on that model Camry. The remedy has posted many times on this
forum. Search Google Groups (archive of the newsgroups) for the answer.


  Reply With Quote
Old 11 May 2006, 02:26 pm   #4 (permalink)
skewe
Guest
  • Posts: n/a
  • User Status:


Default Re: Turn signal blinks fast when breaking

Should be a bulb or a connection that came off... as mentioned earlier
by a poster


---------------------------------------
Golf Deals, Golf Product reviews and more
http://www.golfer-review.com

  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:14 pm.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.