'91 Camry

Reply
 
LinkBack Thread Tools Display Modes
Old 27 Jun 2006, 02:34 pm   #1 (permalink)
Bamm
Guest
  • Posts: n/a
  • User Status:


Default '91 Camry

I have a 1991 Camry with fuel injection. It cranks fine, idles kind of
high but goes into gear smoothly. At the beginning of a drive it
accelerates good and rides good. After a few minutes of driving it
begins to sputter and lose power. It never stalls and if I come to a
complete stop it does not cut off. If I allow it to cool off and try to
drive it, it still sputters and has no power. If I let it sit for a few
days then start it, it begins the cycle all over again.
I have not checked or changed anything yet. I am not really sure where
to start.
Any suggestions?

  Reply With Quote
Old 27 Jun 2006, 03:40 pm   #2 (permalink)
davemac
Guest
  • Posts: n/a
  • User Status:


Default Re: '91 Camry

get your egr valve checked.

dave mc

  Reply With Quote
Old 27 Jun 2006, 04:43 pm   #3 (permalink)
jg
Guest
  • Posts: n/a
  • User Status:


Default Re: '91 Camry


"Bamm" <manuelkennedy2002@hotmail.com> wrote in message
news:1151436874.903747.163100@m73g2000cwd.googlegr oups.com...
>I have a 1991 Camry with fuel injection. It cranks fine, idles kind of
> high but goes into gear smoothly. At the beginning of a drive it
> accelerates good and rides good. After a few minutes of driving it
> begins to sputter and lose power. It never stalls and if I come to a
> complete stop it does not cut off. If I allow it to cool off and try to
> drive it, it still sputters and has no power. If I let it sit for a few
> days then start it, it begins the cycle all over again.
> I have not checked or changed anything yet. I am not really sure where
> to start.
> Any suggestions?
>

I had that (91), the stalks on the plug leads were cracked and floating in
oil. Re-seated the tubes around the plugs in sikaflex and bought new leads
(they come with distributer cap). Runs well now but still wouldn't idle
properly. I found the gearbox kickdown cable was way too loose, that seemed
to fix the idle though it still faulters a little with a/c on. Had tried to
idle it down as it seems too fast, but idle was not stable so I screwed it
back up. At least it doesn't stall now. Does your a/c idle solenoid make a
funny noise? mine has a weird air-sucking noise & I suspect it's not right,
but they are expensive and are not stocked at the local dealer here.


  Reply With Quote
Old 27 Jun 2006, 04:57 pm   #4 (permalink)
m Ransley
Guest
  • Posts: n/a
  • User Status:


Default Re: '91 Camry

A common issue for that model is the ignition coil under the distributor
cap, it gets oil on it from a worn Oring gasket, remove the cap and
clean the coil, or it could just be a bad plug wire, replace them if
old. What you describe is the most common of camry problems of that
model.

  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:14 am.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.