93 AC Question/Problem

Reply
 
LinkBack Thread Tools Display Modes
Old 05 Aug 2006, 12:10 pm   #1 (permalink)
les
Guest
  • Posts: n/a
  • User Status:


Default 93 AC Question/Problem

Greetings, just purchased a 93 Camry 4 cylinder with 184K miles on it
from the original owner. I live in the Dallas, Texas area.

The AC works very good (most of the time). The original owner said
freon (R12) has never been added to it.

The AC blows very cold (amazingly cold) but sometimes the cooling
efficiency starts to decrease and only blows fairly cold air. I notice
the decrease starts on the left vent in the center of the console
first.

I looked at the glass on the ac receiver and it looks kind of foamy.

Could it be:

1) just needs more freon (luckiliy I still have 4 cans left from the
early 90s)
2) or could the evaporator be freezing up with ice crystals? It seems
like I dont' see as much moisture leak off after driving the car for a
long period as I would expcet. Maybe the drain hose is clogged?
3) or something else?

Any help is very much appreciated.

Thanks, Les

  Reply With Quote
Old 05 Aug 2006, 01:07 pm   #2 (permalink)
QQQQ
Guest
  • Posts: n/a
  • User Status:


Default Re: 93 AC Question/Problem

The foam in the sight glass is a sign that the system is low on freon, this
will start to happen on a very hot day as that when the system has the
biggest load. Check it when its cool and see if it clears up, if it does,
then its time to be careful if adding because it might not take that much.
Make sure you are satisfied that you can see the difference between "clear
liquid" and "clear because its empty.

rq




"les" <trazedone@yahoo.com> wrote in message
news:1154797835.629900.274130@m73g2000cwd.googlegr oups.com...
> Greetings, just purchased a 93 Camry 4 cylinder with 184K miles on it
> from the original owner. I live in the Dallas, Texas area.
>
> The AC works very good (most of the time). The original owner said
> freon (R12) has never been added to it.
>
> The AC blows very cold (amazingly cold) but sometimes the cooling
> efficiency starts to decrease and only blows fairly cold air. I notice
> the decrease starts on the left vent in the center of the console
> first.
>
> I looked at the glass on the ac receiver and it looks kind of foamy.
>
> Could it be:
>
> 1) just needs more freon (luckiliy I still have 4 cans left from the
> early 90s)
> 2) or could the evaporator be freezing up with ice crystals? It seems
> like I dont' see as much moisture leak off after driving the car for a
> long period as I would expcet. Maybe the drain hose is clogged?
> 3) or something else?
>
> Any help is very much appreciated.
>
> Thanks, Les
>



  Reply With Quote
Old 05 Aug 2006, 02:36 pm   #3 (permalink)
johngdole@hotmail.com
Guest
  • Posts: n/a
  • User Status:


Default Re: 93 AC Question/Problem

Likely a sign of low freon. Sight glass is for ball park estimates, you
have to use a pressure gauge to check low side pressure.

You may also want to periodically clean the evaporator drain (spiders
can plug it up). So dunno about a frozen expansion valve. Anyone?


les wrote:
> Greetings, just purchased a 93 Camry 4 cylinder with 184K miles on it
> from the original owner. I live in the Dallas, Texas area.
>
> The AC works very good (most of the time). The original owner said
> freon (R12) has never been added to it.
>
> The AC blows very cold (amazingly cold) but sometimes the cooling
> efficiency starts to decrease and only blows fairly cold air. I notice
> the decrease starts on the left vent in the center of the console
> first.
>
> I looked at the glass on the ac receiver and it looks kind of foamy.
>
> Could it be:
>
> 1) just needs more freon (luckiliy I still have 4 cans left from the
> early 90s)
> 2) or could the evaporator be freezing up with ice crystals? It seems
> like I dont' see as much moisture leak off after driving the car for a
> long period as I would expcet. Maybe the drain hose is clogged?
> 3) or something else?
>
> Any help is very much appreciated.
>
> Thanks, Les


  Reply With Quote
Old 08 Aug 2006, 01:04 am   #4 (permalink)
davemac
Guest
  • Posts: n/a
  • User Status:


Default Re: 93 AC Question/Problem


It is probably short of freon by 4-6 oz. The sight glass will appear
foamy possibly or clear (ie. no freon) if the compressor is off. When
it is engaged, it should be clear at 1500RPM. Toyota I believe states
though that it can still appear foamy when the compessor is running at
idle (600 RPM). Again as already stated, you want to check this at the
highest ambient load you can get.

davemc

  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:12 pm.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.