Got a new alternator for my '92 camry LE

Reply
 
LinkBack Thread Tools Display Modes
Old 24 Sep 2006, 12:52 pm   #1 (permalink)
C4MRY_R0X
Guest
  • Posts: n/a
  • User Status:


Default Got a new alternator for my '92 camry LE

Its not working too well. I then noticed that my old alternator was 80
amps and the new one is only 70 amps. Would this cause the alt to not
charge my battery and let it run the car? Coz that's what seems to be
happening.

  Reply With Quote
Old 24 Sep 2006, 02:53 pm   #2 (permalink)
mack
Guest
  • Posts: n/a
  • User Status:


Default Re: Got a new alternator for my '92 camry LE


"C4MRY_R0X" <marino.cabrera@gmail.com> wrote in message
news:1159120325.123250.303430@h48g2000cwc.googlegr oups.com...
> Its not working too well. I then noticed that my old alternator was 80
> amps and the new one is only 70 amps. Would this cause the alt to not
> charge my battery and let it run the car? Coz that's what seems to be
> happening.

~~~~~~~~~~~~~~
Can you elaborate? Is the battery going dead from lack of charge? How
long are your individual trips and how often are you attempting to start the
car? won't the car start? etc.


  Reply With Quote
Old 24 Sep 2006, 03:41 pm   #3 (permalink)
Stubby
Guest
  • Posts: n/a
  • User Status:


Default Re: Got a new alternator for my '92 camry LE



C4MRY_R0X wrote:
> Its not working too well. I then noticed that my old alternator was 80
> amps and the new one is only 70 amps. Would this cause the alt to not
> charge my battery

No, but it will take a bit more time.


and let it run the car?
Other than starting, it takes very little juice to run the car.

Coz that's what seems to be
> happening.
>

  Reply With Quote
Old 24 Sep 2006, 10:42 pm   #4 (permalink)
johngdole@hotmail.com
Guest
  • Posts: n/a
  • User Status:


Default Re: Got a new alternator for my '92 camry LE

There may be other causes in the electrical system. But generally you
want to match the output of the original alternator. There are changes
for Camrys made before and after Aug 1992 from the looks in the
catalogs. So you want to get the right one.

I get my alternators from the local NAPA store. They are reman's (you
can ask they to order new) but are competitively priced along with a
good warranty.




C4MRY_R0X wrote:
> Its not working too well. I then noticed that my old alternator was 80
> amps and the new one is only 70 amps. Would this cause the alt to not
> charge my battery and let it run the car? Coz that's what seems to be
> happening.


  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:40 am.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.