85 camry slows & stalls after 20 mins

Reply
 
LinkBack Thread Tools Display Modes
Old 09 Oct 2006, 02:25 am   #1 (permalink)
rockhard
Guest
  • Posts: n/a
  • User Status:


Default 85 camry slows & stalls after 20 mins

I have an 85 camry manual 5 spd that has been workin great for me and I
love driving it very nice smooth ride. but recently a problem has
arose.
After about 20 minutes of normal driving the car slowly starts to
mis-fire like crazy to the extent that the car starts to deccelerate
and then I have to pull it off to the side of the road and ussualy
stalls if I dont turn it off. Even if I do turn it off ; when I try to
start it again it doesnt start right away, if it does start, the idle
is very rough and if I step on the gas the car accelerates super slow
if not even at all.
the first time it happened I had to leave it on the side of the road
over night and get it towed the next morning. but later I found it
started fine and I took it out for a drive for about 15 minutes then
the same problem started again but I got it home before it totally
died.

I replaced the (fuel filter, spark plugs, distributor cap & rotor, fuel
filter), (checked the ignition coil, cleaned the fuel injectors &
throttle body and did a fuel pressure test everything works fine)
but i am stumped what else could it be

any suggestions welcome Thanks

  Reply With Quote
Old 09 Oct 2006, 08:07 am   #2 (permalink)
m Ransley
Guest
  • Posts: n/a
  • User Status:


Default Re: 85 camry slows & stalls after 20 mins

Its the ignition coil I bet, as it heats up moisture vaporises and
shorts the coil, its a common camry issue, clean the coil, be sure the
cap is tight or replace it if cleaning wont help.

  Reply With Quote
Old 09 Oct 2006, 08:34 am   #3 (permalink)
sroger007
Guest
  • Posts: n/a
  • User Status:


Default Re: 85 camry slows & stalls after 20 mins

I have a virtually the same problem on my 90 camry. I also checked the
distributor and coil. Both pick-ups and primary/secondary coils tested OK
for resistance so I didn't think this was the problem. I still haven't
found the solution yet so I'll be very interested in knowing what works
for you. Although mine checks OK as well I've read many posts that
suggests a malfunctioning engine coolant temp sensor will cause similar
problems - fools the ECU.

  Reply With Quote
Old 09 Oct 2006, 09:18 am   #4 (permalink)
Doctor J
Guest
  • Posts: n/a
  • User Status:


Default Re: 85 camry slows & stalls after 20 mins


The quick check for coolant temp. sensor. Obtain 300 ohm, 2Watt resistor
When engine warms up,shut it off, unplug green connector from the
sensor and insert resistors leads into the terminals.Protect assembly
with tape, then start the engine. if if it runs good now, replace the
sensor. Also make sure, that female terminals inside connector are not
pulled in.


--
Doctor J
------------------------------------------------------------------------
Doctor J's Profile: http://www.toyotanation.com/forum/me...p?userid=53661
View this thread: http://www.toyotanation.com/forum/sh...d.php?t=159442

  Reply With Quote
Old 09 Oct 2006, 10:16 am   #5 (permalink)
Erhan
Guest
  • Posts: n/a
  • User Status:


Default Re: 85 camry slows & stalls after 20 mins

I have the same problem. I already changed the CTS and the distributor
assembly.
Any other ideas?
Thanks

Erhan

  Reply With Quote
Old 09 Oct 2006, 10:59 am   #6 (permalink)
Kurt Krueger
Guest
  • Posts: n/a
  • User Status:


Default Re: 85 camry slows & stalls after 20 mins

sroger007 wrote:

> I have a virtually the same problem on my 90 camry. I also checked the
> distributor and coil. Both pick-ups and primary/secondary coils tested OK
> for resistance so I didn't think this was the problem. I still haven't
> found the solution yet so I'll be very interested in knowing what works
> for you. Although mine checks OK as well I've read many posts that
> suggests a malfunctioning engine coolant temp sensor will cause similar
> problems - fools the ECU.
>


The temp sensor could cause problems, but it should happen as soon as the
car warms up. Not 20 minutes later. I believe the 85 has a temperature
gauge. If the behavior correlates with engine temperature, than it's
probably the coolent sensor (which is different from the one running the
gauge). Price at NAPA should be under $20.

Toyota's have had problems with coil/ignitor assemblies being heat
sensitive. My '83 was recalled about 6 months after I bought it
to replace the ignitor. The only way to know for sure is to replace
it with a known good unit. New ones are absurdly priced, so it's
not a cheap experiment. Junk yards are a good source, but it's hard
to know if you have a good one.
  Reply With Quote
Old 09 Oct 2006, 11:05 am   #7 (permalink)
Doctor J
Guest
  • Posts: n/a
  • User Status:


Default Re: 85 camry slows & stalls after 20 mins


In rare instances, the beginning of a fuel pump failure shows up this
way. One time (83 Camry) the pump discharge port strainer became
separated and plugged pressure line. The fragment was removed by
blowing the air from the fuel filter side down to the pump.


--
Doctor J
------------------------------------------------------------------------
Doctor J's Profile: http://www.toyotanation.com/forum/me...p?userid=53661
View this thread: http://www.toyotanation.com/forum/sh...d.php?t=159442

  Reply With Quote
Old 09 Oct 2006, 10:42 pm   #8 (permalink)
rockhard
Guest
  • Posts: n/a
  • User Status:


Default Re: 85 camry slows & stalls after 20 mins

Hey I found my problem.. I feel kinda stupid. but at first when I was
doing the fuel pressure test I disconected the gas line and physically
tested what the pressure was like with my hands and then did so after
the car was warmed up didnt seem like any difference at all....
I talked to my uncle (a mechanic) and he let me borrow his actuall fuel
gauge tester. After all that I found that a 85 camrys normal fuel line
PSI is 33 - 38 psi.
I took my car for a drive with it hooked up and saw that the psi
started dropping from 30 and ended up around 15 psi when the car
sounded like it was gonna stall.. so it was my fuel pump Ahhh...

  Reply With Quote
Old 10 Oct 2006, 08:10 am   #9 (permalink)
Daniel
Guest
  • Posts: n/a
  • User Status:


Default Re: 85 camry slows & stalls after 20 mins

rockhard wrote:
> Hey I found my problem.. it was my fuel pump

========================
Just curious ---

Did you often drive with gasoline less than quarter tank full?

  Reply With Quote
Old 22 Oct 2006, 02:27 pm   #10 (permalink)
rockhard
Guest
  • Posts: n/a
  • User Status:


Default Re: 85 camry slows & stalls after 20 mins


Daniel wrote:
> rockhard wrote:
> > Hey I found my problem.. it was my fuel pump

> ========================
> Just curious ---
>
> Did you often drive with gasoline less than quarter tank full?



Yes actually I did and I think that would probably be part of my
problem anyways I make sure I dont run it empty to much anymore

  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:56 am.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.