How to test 7MGE ign control module? Hit & miss starting problem 89 Cressida

Reply
 
LinkBack Thread Tools Display Modes
Old 16 Sep 2013, 07:00 pm   #1 (permalink)
docsavage20@yahoo.com
Guest
  • Posts: n/a
  • User Status:


Default How to test 7MGE ign control module? Hit & miss starting problem 89 Cressida

My '89 Cressida with 7MGE has developed a problem where it takes numerous tries to start.

Crank a few - pause - crank a few - pause - crank a few - pause - crank a few - starts

Once it finally starts it runs like a clock. No problem. It got worse over the period of probably a month or so - now it does it pretty consistently when cold but will also do it after getting up to operating temp and sittingfor 5 - 20 mins. If I turn it off and restart immediately it will fire up again. Sometimes it will start right up cold too.

The immediate cause is clearly no spark as per inductive timing light. Thensuddenly there's spark and it runs. I've determined there's fuel - disconnected the fitting to the fuel rail when symptoms show up, wrapped it in paper towels and cranked - fuel is flowing.

So, what does this suggest? ICM going funky? What other culprits?

What's a good way to test the ICM?

Thanks for all input.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:45 am.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.