Oil change lights on Toyota matrix?

Reply
 
LinkBack Thread Tools Display Modes
Old 18 Sep 2010, 05:39 pm   #1 (permalink)
Junior Member
  • Join Date: Sep 2010
  • Posts: 1
  • User Status: Offline


Default Oil change lights on Toyota matrix?

Hello, I'm a new owner of a toyota matrix and I'm not really sure if something wrong is happening on my car.































I got the "maintenance required" and "oil change" lights on but just when I turn the key to the first stage before to turn on the engine. When I turn the engine the lights came off. Is that normal or do I have to take my car to the dealer to check it?















Well, so the light of oil change are supposed to be on when driving?















Well, I bought the car a week ago and it's a certified vehicle so it might be an indicator that the light is working or things like that
  Reply With Quote
Old 18 Sep 2010, 05:55 pm   #2 (permalink)
Senior Member
  • Join Date: Feb 2010
  • Posts: 388
  • User Status: Offline


Default

Normal. Most vehicles do this. Its to show you that the lights are working
  Reply With Quote
Old 18 Sep 2010, 06:09 pm   #3 (permalink)
Senior Member
  • Join Date: Jul 2010
  • Posts: 129
  • User Status: Offline


Default

it's call idiot light i think, when all the lights on the dash lights up with key on































maintenance light is just a reminder for a oil change after around 5k miles and should be reset after a oil change.































the oil light should not be on while driving.















most likely you have low engine oil, check your engine oil level by looking at the yellow dip stick around your engine. it should be between the two dot. do it with the engine off.
  Reply With Quote
Old 18 Sep 2010, 06:25 pm   #4 (permalink)
Member
  • Join Date: Mar 2010
  • Posts: 85
  • User Status: Offline


Default

It's normal.















Now when driving, and the red oil light indicator appears is when something is wrong.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:38 pm.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.