2003 Highlander quit on highway and now won't start

Reply
 
LinkBack Thread Tools Display Modes
Old 26 Apr 2017, 12:15 pm   #1 (permalink)
Junior Member
  • Join Date: Apr 2017
  • Posts: 1
  • User Status: Offline


Question 2003 Highlander quit on highway and now won't start

I have a 03 toyota highlander V6 3.0L and without any warning the engine just quit running while on interstate. Pulled over to side of interstate n checked oil, hoses,etc n everything fine. But tried to start it after sitting a little while my battery was dead. Tow truck came and tried to jump it off and still did not start. Also started making a yelping noise that it has never done before when cranking that sounds like it is coming from the starter.Alternator makes no noise once charged battery up. Fuel pump assembly working great. Put OBD II Scanner and only codes were a oxygen sensor heater circuit and knock sensor. Fuel pump relays are in working condition as so is oil pump. Motor is not bound up nor did it jump time. Timing belt in great condition. It is getting fire to each plug but they do need changing. My car never skipped or back fired at any time. The plugs were wet when removed them to inspect them after we got it home and was trying to get it to start. As I've read and researched thought it may be Mass Flow Senor. I do not know though what the readings are supposed to be so unsure it is working properly. Can you tell me what it's supposed to read with a multi meter? Checked crank position and cam position sensors and all are pulsing voltage. Do you happen to know is there anything else I should check? All fuses are good have not found any blown.. at wits end, please help.
  Reply With Quote
Old 10 May 2017, 03:09 am   #2 (permalink)
Junior Member
  • Join Date: Feb 2017
  • Posts: 7
  • User Status: Offline


Default Re: 2003 Highlander quit on highway and now won't start

Howdy! Sorry about the issue. What particular codes the scanner got? Start looking at your alternator and try to replace the O2 and mass flow sensors.
  Reply With Quote

Reply

Tags
2003, 3liter, highlander, nostart

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:15 pm.

Attribution:
Autoblog
Powered by Yahoo Answers



ToyotaLexusForum.com is an unofficial community for car enthusiasts. ToyotaLexusForum.com is not affiliated with Toyota Motor Corporation in any way.
Toyota Motor Corporation does not sponsor, support, or endorse ToyotaLexusForum.com in any way.
Copyright/trademark/sales mark infringements are not intended or implied.